Cómo determinar si un número es positivo o negativo en PseInt

En PseInt 2019 es posible verificar si un número es positivo o negativo, simplemente usando un condicional que verifique si el numero es mayor a 0. En caso de que el número sea mayor a 0, el número es positivo, de lo contrario el número es negativo.

El siguiente algoritmo permite la lectura de una variable entera llamada num del tipo entero. El usuario ingresa el número y de acuerdo al signo imprimirá si es negativo o positivo:

Algoritmo TestSignos
	Definir num Como Entero
	
	Escribir "Ingresa el numero a determinar"
	Leer num
	
	Si num > 0 Entonces
		Escribir "El numero es positivo"
	SiNo
		Escribir "El numero es negativo"
	FinSi
FinAlgoritmo

Que te diviertas !

Podría ser de tu interes
Conviertete en un programador más sociable