Cómo imprimir los primeros N multiplos de un número en PseInt

Cómo imprimir los primeros N multiplos de un número en PseInt

En algunos ejercicios en clase, tendrás que averiguar el multiplo de un número. Esta lógica de los multiplos de un número se basa en una sencilla regla, un número es multiplo de otro cuando al dividir el número que necesitas saber si es multiplo, entre el número como tal, por ejemplo, para saber si 15 es multiplo de 5, el residuo de la operación al divir 15/5 debería ser 0:

Nota: hablamos de el residuo de la operación, no el resultado de la división es decir, 15/3 = 3 sin embargo necesitamos es el residuo de dicha operación, es decir el operador módulo (MOD o % en PseInt).

# Operador Módulo
15 % 5 = 0

Esto quiere decir que al dividir 15 entre 3, el residuo de dicha operación es 0, por lo tanto 15 es multiplo de 5. Ahora, si necesitas averiguar los primeros X o N números multiplos de algún número, deberás recurrir a un ciclo indefinido que se detendrá solamente cuando alguna variable contadora/bandera le indique que debe finalizar. En este caso nosotros trabajaremos con 3 variables que funcionarán como contadores. La variable contador va a contener el número que vamos a dividir para saber si es multiplo del número ingresado, por lo tanto este incrementará gradualmente por 1 hasta que la variable "limite" que contiene el indice actual del total de números que han sido declarados como multiplos del número ingresado:

Algoritmo NPrimerosMultiplos
	Definir _numero, contador, limite, numeroMultiplos Como Entero
	
	Escribir "Ingresa el número de multiplos a calcular:"
	Leer numeroMultiplos
	
	Escribir "Ingresa el valor de numero para calcular sus primeros ", numeroMultiplos ," multiplos:"
	Leer _numero
	
	limite = 1
	contador = 1
	
	Repetir
		Si contador MOD _numero = 0 Entonces
			Escribir limite, ") ", contador
			limite = limite + 1
		FinSi
		
		contador = contador + 1
		
	Hasta Que limite > numeroMultiplos
FinAlgoritmo

Que te diviertas !

Esto podría ser de tu interes

Conviertete en un programador más sociable