Cómo imprimir el borde de un cuadrado vacío con asteriscos en PseInt

Cómo imprimir el borde de un cuadrado vacío con asteriscos en PseInt

Para muchos ejercicios de práctica y entendimiento sobre ciclos definidos en programación, necesitarás hacer ejercicios que aunque no tienen implicación en la vida real son bastante útiles para comprender en su totalidad los ciclos. Uno de los mas comunes es el de crear la figura de un cuadrado, sin embargo sin relleno, solamente sus bordes. Esto se puede lograr con un ciclo dentro de otro ciclo fácilmente y usando la instrucción Escribir Sin Saltar con el fin de imprimir caracteres seguidos en la misma linea:

Algoritmo BordeCuadrado
	Definir numeroLados, contador Como Entero
	
	Escribir "Ingrese la longitud de los lados:"
	Leer numeroLados
	
	Para a<-1 Hasta numeroLados Con Paso 1 Hacer
		Para b<-1 Hasta numeroLados Con Paso 1 Hacer
			Si a == 1 O a == numeroLados O b == 1 O b == numeroLados Entonces
				Escribir Sin Saltar "* "
			SiNo
				Escribir Sin Saltar "  "
			FinSi
		Fin Para
		
		Escribir ""
	Fin Para
FinAlgoritmo

Que te diviertas !

Esto podría ser de tu interes

Conviertete en un programador más sociable