Cómo imprimir los primeros N números de la serie de Fibonacci en PseInt

Cómo imprimir los primeros N números de la serie de Fibonacci en PseInt

En multiples ejercicios de practica en la escuela o universidad, tendrás en algun momento que elaborar un programa que imprima los N primeros números de la famosa serie de Fibonacci. p. ej: 0, 1, 1, 2, 3, 5, 8, 13, 21, 34. Esta serie se describe de una manera corta, asumiendo que cada número se obtiene a partir de la sumatoria de los dos números anteriores de la serie.

Esta sucesión fue descrita por Fibonacci como la solución a un problema de cría de conejos: “Cierto hombre tiene una pareja de conejos juntos en un lugar cerrado y desea saber cuántos son creados a partir de este par en un año cuando, de acuerdo a su naturaleza, cada pareja necesita un mes para envejecer y cada mes posterior procrea otra pareja” (Laurence Sigler, Fibonacci’s Liber Abaci, página 404).

La respuesta a esta pregunta es la que sigue:

  • Partimos de una pareja de conejos el primer mes.
  • El segundo mes la pareja envejece pero no procrea.
  • El tercer mes la pareja procrea otra pareja (es decir, ya tenemos dos parejas).
  • El cuarto mes, la primera pareja vuelve a procrear y la pareja nueva envejece sin procrear (luego tenemos tres parejas).
  • El quinto mes, las dos parejas más viejas vuelven a procrear mientras que la nueva pareja no procrea (cinco parejas en total)

Partiendo de los números 0 y 1, los números de Fibonacci quedan definidos por la función:

fn = (fn - 1) + (fn - 2)
f0 = 0
f1 = 1
f2 = f1 + f0 = 1
f3 = f2 + f1 = 2

Por lo tanto, la implementación mas sencilla y fácil de entender la serie de fibonacci en PseInt sería:

Algoritmo SerieFibonacci
	Definir _numero, a, b, tmp como Entero
	
	Escribir "- Serie de Fibonacci -"
    Escribir "	Por favor ingrese la cantidad de números de la serie que se imprimirán:"
    Leer _numero
	
    b = 1
	
    Para i<-1 Hasta _numero Hacer
        Escribir a
        tmp = a + b
        a = b
        b = tmp
    FinPara
FinAlgoritmo

Que te diviertas !

Esto podría ser de tu interes

Conviertete en un programador más sociable