Cómo solucionar error en Android cordova (Please install Android target: "android-x")

Cómo solucionar error en Android cordova (Please install Android target: "android-x")

Cuando recibes el conocido error (fatal) "Please install Android target: xx" ejecutando cualquiera de lo comandos para compilar tu aplicación ya sea en cordova, ionic o phonegap, por ejemplo ionic run android, cordova run android o cordova build android, el mensaje indica que tu computadora no tiene la version del SDK apropiado para compilar tu aplicación.

Para solucionar el problema inicia el manager de SDK (localizado en el directorio de instalación del SDK de android [sdkmanager.exe]).

Image

Verifica que la versión especificada para compilar tu aplicación (targetSdkVersion en AndroidManifest.xml usualmente localizado en tuproyecto\platforms\android) de tu proyecto coincide con alguno de los SDKs instalados en tu computadora:

<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="23" />

Finalmente, instala simplemente la versión que requiere tu aplicación en el manifiesto en el Manager de SDKs seleccionando de la lista la API correspondiente.

Nota: incluso si apuntas a la versión 16 (o cualquiera) y el problema persiste, simplemente reinicia la consola de comandos, abrela nuevamente e intenta de nuevo. Si el problema persiste y ya tienes instalado el SDK requerido, reinicia tu computadora y el problema debería estar solucionado una vez intentes de nuevo.

Esto podría ser de tu interes

Conviertete en un programador más sociable